Loom device compatibility

Minimum system requirements in order to use the Loom Desktop App. ūü§Ě¬†

Recording multiple streams of video alongside audio can be taxing on your computer. For this reason, we've put together some minimum system requirement guidelines to ensure your device and Loom's compatibility. 

‚ö†ÔłŹ Anything less than the below will not support the successful operation of the Loom desktop app.¬†¬†

Desktop App:

Operating System Requirments

Windows 

Windows7 or above (64-bit only)
Intel Pentium 4 processor or later that's SSE2 capable
With at least 512 MB of RAM (at least 4GB recommended)

macOS

OSX 10.10 or above (64-bit only)
With at least 512 MB of RAM (at least 4GB recommended)

iOS (mobile)  iOS 12.1 or above
 Compatible with iPhone, iPad, and iPod touch 


In browser viewing a video: 

  Requirments
Chrome Latest version 
Firefox  Latest version 
Safari  Latest version
Edge Latest version 
Internet Explorer  IE 11 and above (IE 10 and older are not supported)


FAQs

What if my device is 32-bit?

Although you can't use the Loom Desktop app, you can still record via our Loom Chrome Extension. 

Do you support Linux or Chrome OS?
Unfortunately not, we'd love to bring these to the Loom platform, but at the moment we only have  Windows and Mac desktop apps. You can check out our public roadmap here. 

 

 

1 out of 1 found this helpful

Comments

0 comments

Article is closed for comments.